AfterShip Shipping and Tracking: UPS label generation intermittent issue [February 21st, 2025 at 8:09 AM UTC]

Incident Report for AfterShip

Resolved

This incident is resolved. All services are back to normal.
Posted Feb 21, 2025 - 04:49 EST

Monitoring

Services are recovering. We are monitoring the results.
Posted Feb 21, 2025 - 04:16 EST

Update

We are continuing to investigate this issue.
Posted Feb 21, 2025 - 04:14 EST

Update

We are continuing to investigate this issue.
Posted Feb 21, 2025 - 03:43 EST

Update

Issue identified as service outage at carrier's end
Posted Feb 21, 2025 - 03:35 EST

Investigating

We are currently facing issues with UPS label generation services due to carrier system unavailability. Following services are impacted:
AfterShip Shipping:
- UPS Label Creation,
- UPS Shipping Rate Calculation
- UPS Label Cancellation

AfterShip Tracking:
- Tracking updates are delayed
Posted Feb 21, 2025 - 03:18 EST
This incident affected: Couriers Tracking System and Couriers Shipping System.