[royal-mail] is currently unavailable

Incident Report for AfterShip

Resolved

The incident has been resolved and the services are fully operational.
Posted Oct 20, 2024 - 04:27 EDT

Update

Royal Mail website is down Impacting Tracking updates.

Our team is dedicatedly working on this concern to get it fixed as soon as possible. We'll keep you posted on the progress.

We appreciate your patience with us.
Posted Oct 19, 2024 - 22:18 EDT

Update

We are continuing to investigate this issue.
Posted Oct 19, 2024 - 22:15 EDT

Investigating

We have been facing issues while getting the tracking updates for the carrier "royal-mail" since 2024-10-19 23:00

Our team is working on priority to fix it. We'll update you on the progress.
Posted Oct 19, 2024 - 21:42 EDT
This incident affected: Couriers Tracking System, Couriers Shipping System, Support, and Third party services.