GLS is experiencing some technical problems and we are not getting tracking updates.
Incident Report for AfterShip Tracking
Resolved
Thank you for your patience, the official website of GLS has been recovered along with our courier.
Posted Apr 14, 2023 - 06:30 EDT
Investigating
GLS is experiencing some Internal system error and we are not getting tracking updates.

Our team is in touch with them to fix it on priority. We'll keep you updated.
Posted Apr 14, 2023 - 05:16 EDT
This incident affected: Couriers Tracking System.