USPS Label Generation Failure. Start Time - 2026/01/27 15:32 UTC

Incident Report for AfterShip

Identified

We are working with USPS to resolve it as soon as possible.
Posted Jan 27, 2026 - 12:19 EST

Investigating

Users may receive a rate limit error while generating a label for USPS carrier. We are currently investigating this issue.
Posted Jan 27, 2026 - 11:36 EST
This incident affects: Couriers Shipping System.