Carrier DPD France (Slug: exapaq) is currently unavailable. Start Time:- 2026/01/28 13:00 UTC

Incident Report for AfterShip

Update

We are continuing to investigate this issue.
Posted Jan 28, 2026 - 10:36 EST

Investigating

Carrier DPD France (Slug: exapaq) is currently unavailable. Tracking updates may be affected.
Posted Jan 28, 2026 - 10:36 EST
This incident affects: Couriers Tracking System.