[spanish-seur] is currently unavailable
Incident Report for AfterShip Tracking
Resolved
The incident has been resolved and the service is fully operational.
Posted Jan 09, 2024 - 02:20 EST
Investigating
We are facing issues while getting the tracking updates from the carrier "spanish-seur" from 2023-10-24 19:26 (UTC+8)

Our team is monitoring and working on getting this fixed on priority.
Posted Oct 26, 2023 - 00:34 EDT
This incident affected: Couriers Tracking System.