[yto] is currently unavailable
Incident Report for AfterShip Tracking
Resolved
The carrier has been fixed and the services are back to operational.
Posted Jun 06, 2024 - 05:56 EDT
Update
We are continuing to investigate this issue.
Posted Jun 04, 2024 - 05:35 EDT
Investigating
We have been facing issues while getting the tracking updates for the carrier "yto" since 2024-05-16 18:30 HKT

We are working to fix it on priority. We'll keep you updated on the progress.
Posted Jun 04, 2024 - 05:33 EDT
This incident affected: Couriers Tracking System.