DHL eCommerce UK Label Generation Failure - Start Time 2025/10/29 16:00 PM UTC - End time 2025/10/30 09:18 AM UTC

Incident Report for AfterShip

Resolved

This incident has been resolved.
Posted Oct 30, 2025 - 05:31 EDT

Update

DHL eCommerce UK carrier's services are operational now.
Posted Oct 30, 2025 - 04:54 EDT

Update

The DHL eCommerce UK services are recovering. We will continue monitoring.
Posted Oct 30, 2025 - 04:38 EDT

Investigating

DHL eCommerce UK Services are unavailable, resulting in label generation failure. We are checking with the carrier and will post further updates.
Posted Oct 29, 2025 - 16:36 EDT
This incident affected: Couriers Shipping System.