Carrier DPD Romania [dpd-ro] Is Unavailable - Start Time: 2025/11/28 9:00 UTC

Incident Report for AfterShip

Update

We are continuing to investigate this issue.
Posted Dec 04, 2025 - 08:11 EST

Update

We are continuing to investigate this issue.
Posted Dec 03, 2025 - 00:32 EST

Update

We are continuing to investigate this issue.
Posted Dec 01, 2025 - 00:47 EST

Investigating

The carrier DPD Romania (Slug: dpd-ro) API is unavailable resulting in no tracking updates.
Posted Nov 28, 2025 - 11:36 EST
This incident affects: Couriers Tracking System.