Carrier DPD France[Formerly Exapaq] Is Currently Unavailable - Start Time: 2026/01/19 1:23 PM UTC - End Time 2026/01/21 10:11 AM UTC

Incident Report for AfterShip

Resolved

This incident has been resolved.
Posted Jan 21, 2026 - 05:23 EST

Update

We are continuing to investigate this issue.
Posted Jan 21, 2026 - 05:23 EST

Investigating

The Carrier DPD France (Formerly Exapaq) is currently available resulting in no tracking updates for associated shipments. We are investigating this further.
Posted Jan 20, 2026 - 01:07 EST
This incident affected: Couriers Tracking System.