[aramex] is currently unavailable
Incident Report for AfterShip Tracking
Resolved
The carrier has recovered and the services are back to operational.
Posted Apr 30, 2024 - 05:53 EDT
Update
We are continuing to investigate this issue. We appreciate your patience.
Posted Apr 29, 2024 - 22:04 EDT
Investigating
We have been facing issues while getting the tracking updates for the carrier "aramex" since 2024-04-28 18:36 HKT. It seems aramex web is upgrading it’s website.

Our Engineers are working to fix it on priority. We'll update you on the progress.
Posted Apr 29, 2024 - 00:06 EDT
This incident affected: Couriers Tracking System.