Notifications: Webhook Processing Delay
Incident Report for AfterShip Tracking
Resolved
This incident has been resolved.
Posted Nov 25, 2020 - 15:59 EST
Update
All services are normal now.
Posted Nov 25, 2020 - 15:58 EST
Update
AWS is down:
- Sending webhook notifications delayed by 60 mins now.
- Order sync is recovered, however, the team is monitoring.
Posted Nov 25, 2020 - 14:55 EST
Update
AWS is down:
- Sending webhook notifications delayed by 80 mins now.
- Order sync is also recovering.
Posted Nov 25, 2020 - 14:27 EST
Update
AWS is down again:
- Problem observed sending webhook notifications
- Order sync is affected as well
Posted Nov 25, 2020 - 13:56 EST
Identified
AWS is down again:
- Sending webhook notifications delayed by 40 mins now
- Order sync is affected as well
Posted Nov 25, 2020 - 11:46 EST
Update
Affected carriers: Recovered
Order Sync: Recovered
Webhook notification: Recovering (30 mins delay now)
Posted Nov 25, 2020 - 11:13 EST
Monitoring
A fix has been implemented and the data has started recovering.
Posted Nov 25, 2020 - 10:40 EST
Update
The impact of AWS issue is on the below services:
- Sending webhook notifications delayed
- Delayed updates for around 20 carriers
- Order sync will be delayed, however, no concern related to the data loss

The team is finding RTO methods to resume the services ASAP.
Posted Nov 25, 2020 - 10:29 EST
Identified
We are currently experiencing around 30 mins of delay in webhooks processing due to an ongoing issue with our service provider (AWS). Hoping to get this resolved soon
Posted Nov 25, 2020 - 10:13 EST
This incident affected: Secure Web Portal.