The courier GLS netherlands is currently unavailable and team is in touch with them to fix it
Incident Report for AfterShip Tracking
Resolved
Thank you for your patience, The GLS Netherlands is available now.

We are now getting updates and we are keeping an eye on it to look for any lag.
Posted Jul 19, 2023 - 23:03 EDT
Investigating
GLS Netherlands is currently unavailable, and this will impact our users who use this carrier for shipping.

Our team is in touch with them to get it fixed. We'll keep you posted.

We appreciate your patience.
Posted Jul 14, 2023 - 04:38 EDT
This incident affected: Couriers Tracking System.