ECMS Carrier Integration Unavailable

Incident Report for AfterShip

Resolved

The carrier has recovered and is back to normal now.
Posted Jul 02, 2025 - 00:32 EDT

Update

We are continuing to investigate this issue.
Posted Jul 01, 2025 - 22:31 EDT

Investigating

We are currently experiencing an incident involving the ECMS carrier. ECMS carrier tracking is currently non-operational.
Posted Jul 01, 2025 - 22:29 EDT
This incident affected: Third party services.