Missing Return Label Action Button in Return Email Notifications

Incident Report for AfterShip

Resolved

The service has been restored. Affected historical data will be restored by the end of the day today.
Posted Aug 22, 2025 - 14:39 EDT

Investigating

Return emails are currently not showing the usual download button for return labels. Labels are still being generated, and the team is working to restore the button display.
Posted Aug 22, 2025 - 14:22 EDT
This incident affected: Admin Portal (Returns).