Webhook and API Response Delay
Incident Report for AfterShip Tracking
Resolved
The incident has been resolved and the services are operational.
Posted Dec 30, 2020 - 12:34 EST
Update
Webhooks are recovering and the delay is now below 30 mins.
Posted Dec 30, 2020 - 12:11 EST
Monitoring
The team has fixed the API issue and the response time is now back to normal. We are going to monitor the system for some time.
Webhooks are still delayed by ~40 mins.
Posted Dec 30, 2020 - 11:47 EST
Update
Webhooks are now experiencing a delay of ~45 mins.
Posted Dec 30, 2020 - 11:20 EST
Identified
We are currently facing delay issues with api.aftership.com.
- POST tracking response time increased from ~150ms to 750ms
- GET tracking response time increased from ~200ms to 900ms
- Webhook delay is around 30 minutes.

The team is working on fixing it at the earliest.
Posted Dec 30, 2020 - 11:05 EST
This incident affected: API.