[ontrac] is currently unavailable
Incident Report for AfterShip Tracking
Resolved
The "ontrac" is back to operational now. We appreciate your patience.
Posted Mar 15, 2024 - 06:23 EDT
Investigating
We are currently experiencing issues while getting the tracking updates from the carrier "ontrac" due to carrier endpoint is changed from 11:00 AM HKT.

Our Engineers are working to fix it on priority. We'll update you the progress.
Posted Mar 15, 2024 - 04:00 EDT
This incident affected: Couriers Tracking System.