[tforce-finalmile] is currently unavailable
Incident Report for AfterShip
Resolved
The incident has been resolved and the service is fully operational from 2023-10-18 01:42 (UTC+8)
Posted Oct 18, 2023 - 00:36 EDT
Update
We are continuing to investigate this issue.
Posted Oct 17, 2023 - 04:18 EDT
Investigating
We are facing issues while getting the tracking updates from the carrier "tforce-finalmile" from 2023-10-16 07:16 (UTC+8)

Our team is working on getting this fixed on priority.
Posted Oct 16, 2023 - 05:47 EDT
This incident affected: Couriers Tracking System.