[usps] is currently unavailable
Incident Report for AfterShip
Resolved
The incident has been resolved and the services are fully operational.
Posted Nov 11, 2024 - 08:54 EST
Investigating
We have been facing issues while getting the tracking updates for the carrier "usps" since 2024-11-11 09:25:00 HKT.

Our team is working on a priority to fix it. We'll update you on the progress.
Posted Nov 11, 2024 - 05:57 EST
This incident affected: Couriers Tracking System.