Canada Post carrier is unstable - Start Time - 2026/03/15 20:30 UTC - End Time - 2026/03/16 23:20 UTC

Incident Report for AfterShip

Resolved

This incident has been resolved.
Posted Mar 15, 2026 - 22:28 EDT

Investigating

Canada Post is currently unstable - Label Generation is affected.
Posted Mar 15, 2026 - 22:23 EDT
This incident affected: Couriers Shipping System.