[ilyanglogis] is currently partially unavailable

Incident Report for AfterShip

Resolved

All services are operational now.
Posted Feb 27, 2025 - 04:51 EST

Investigating

We are working on it and keep you updated on the progress.
Posted Feb 27, 2025 - 03:19 EST
This incident affected: Couriers Shipping System.