Chat Support Outage (Tool - Crisp) | Start Time: 2025/11/03 14:00 UTC - End Time: 2025/11/03 14:25 UTC

Incident Report for AfterShip

Resolved

This incident has been resolved.
Posted Nov 03, 2025 - 09:29 EST

Identified

The issue has been identified and a fix is being implemented.
Posted Nov 03, 2025 - 09:20 EST

Investigating

Our chat support provider (Crisp) is currently facing issues with their services. For any urgent queries, please reach out to us at support@aftership.com
Posted Nov 03, 2025 - 09:20 EST
This incident affected: Third party services.