[jt-logistics] is currently unavailable
Incident Report for AfterShip Tracking
Resolved
The incident has been resolved and the service is fully operational.
Posted Aug 28, 2023 - 05:18 EDT
Update
We are continuing to investigate this issue and will keep the status update.
Posted Aug 28, 2023 - 01:45 EDT
Update
We are continuing to investigate this issue.
Posted Aug 23, 2023 - 06:58 EDT
Investigating
The slug "jt-logistics" is unavailable from 2023-08-23 05:10:00 (UTC+8)

Our team is in working to resolve the issue. We'll keep you posted.
Posted Aug 23, 2023 - 06:56 EDT
This incident affected: Public Web Portal and Couriers Tracking System.