[envialia] is currently unavailable
Incident Report for AfterShip Tracking
Resolved
Now the incident has been resolved and the service is fully operational.
Posted Jan 26, 2024 - 01:16 EST
Update
We are continuing to investigate this issue.
Posted Jan 19, 2024 - 01:45 EST
Update
We are continuing to investigate this issue.
Posted Jan 18, 2024 - 23:11 EST
Investigating
We are currently experiencing issues while getting the tracking updates from the carrier "envialia"

We have reached out to the carrier to get it resolved at the earliest.
Posted Jan 18, 2024 - 23:10 EST
This incident affected: Couriers Tracking System.