[interlink-express-reference] is currently unavailable
Incident Report for AfterShip
Resolved
The incident has been resolved and the services are fully operational.
Posted Nov 06, 2024 - 20:28 EST
Update
Our team is still working to get this fixed. We appreciate your patience with us.
Posted Nov 06, 2024 - 19:03 EST
Investigating
We have been facing issues while getting the tracking updates for the carrier "interlink-express-reference" since 2024-11-06 06:40 HKT.

Our team is working on a priority to fix it. We'll update you on the progress
Posted Nov 06, 2024 - 01:23 EST
This incident affected: Couriers Tracking System.