USPS Tracking application under maintenance.
Incident Report for AfterShip Tracking
Resolved
Thank you for your patience. The incident has been resolved.
Posted Feb 24, 2023 - 07:46 EST
Investigating
USPS is currently experiencing issues with its Tracking Application. They are working to resolve this on priority.

We will keep monitoring and update here once they recover.
Posted Feb 24, 2023 - 06:52 EST
This incident affected: Couriers Tracking System.