[lietuvos-pastas] is currently unavailable

Incident Report for AfterShip

Resolved

The incident has been resolved.
All services are back to normal and operational.
Posted Feb 19, 2025 - 05:44 EST

Update

We are still working on it and will keep you updated on our progress.
Posted Feb 18, 2025 - 12:56 EST

Investigating

We have been facing issues while getting the tracking updates for the carrier "lietuvos-pastas" since 2024-02-17T14:00:00 UTC.

We are working on it and keep you updated on the progress.
Posted Feb 17, 2025 - 22:17 EST
This incident affected: Couriers Tracking System.