[usps] is currently partially unavailable
Incident Report for AfterShip
Resolved
The incident has been resolved and the services are fully operational.
Posted Nov 17, 2024 - 21:58 EST
Investigating
We have been facing issues while getting the tracking updates for the carrier "usps" since 09:10:00 HKT November 17, 2024

Our team is working on priority to fix it. We'll update you on the progress.
Posted Nov 17, 2024 - 04:24 EST
This incident affected: Couriers Tracking System.