AfterShip SMS: Notifications And Marketing SMS Outage - Start Time: 2025/10/20 7:10 AM UTC, End time: 2025/10/20 12:45 PM UTC

Incident Report for AfterShip

Resolved

The incident has been resolved. Services are back to normal
Posted Oct 20, 2025 - 08:55 EDT

Investigating

AfterShip SMS - Notifications and Marketing are disrupted due Twillio's (AfterShip's vendor) service interruption impacted by AWS outage.
We will keep posted on further development.
Posted Oct 20, 2025 - 06:12 EDT
This incident affected: Third party services.