[shreetirupati] is currently unavailable
Incident Report for AfterShip
Resolved
The incident has been resolved and the services are fully operational.
Posted Nov 20, 2024 - 01:49 EST
Update
We are continuing to investigate this issue.
Posted Nov 19, 2024 - 00:56 EST
Update
We are continuing to investigate this issue.
Posted Nov 19, 2024 - 00:53 EST
Update
We are continuing to investigate this issue.
Posted Nov 19, 2024 - 00:53 EST
Investigating
We have been facing issues while getting the tracking updates for the carrier "shreetirupati" since 2024-11-18 22:00:00 HKT.

We are working on it and keep you updated on the progress.
Posted Nov 18, 2024 - 21:45 EST
This incident affected: Couriers Tracking System.