AfterShip courier DHL and dhl-pieceid are down
Incident Report for AfterShip
Resolved
The incident has been resolved.
Posted Jun 22, 2021 - 03:27 EDT
Monitoring
The fix has been deployed and the courier is recovered. We are still monitoring to make sure everything is going well.
Posted Jun 22, 2021 - 02:26 EDT
Identified
The team has identified the issue and they are implementing a fix to resolve the issue.
Posted Jun 21, 2021 - 10:07 EDT
Investigating
AfterShip Courier DHL and DHL-pieceid are down since 10 AM HKT, The team is currently investigating the issues.
Posted Jun 20, 2021 - 23:39 EDT
This incident affected: Couriers Tracking System.