[kerry-logistics] is Currently Unavailable - Start time: 2025-09-02 04:00:00 UTC

Incident Report for AfterShip

Resolved

This incident has been resolved.
Posted Sep 02, 2025 - 20:56 EDT

Update

We are in touch with the carrier and are awaiting their response. We will keep the updates posted here.
Posted Sep 02, 2025 - 09:13 EDT

Investigating

We are currently facing issues with carrier Kerry Express Thailand [slug: kerry-logistics]. We have reached out to the carrier to resolve the issue.
Posted Sep 02, 2025 - 06:41 EDT
This incident affected: Couriers Tracking System.