Carrier canada-post is unstable - Start Time - 2026/06/10 01:55 UTC - End Time - 2026/06/10 03:06 UTC

Incident Report for AfterShip

Resolved

This incident has been resolved.
Posted Jun 09, 2026 - 23:06 EDT

Investigating

Carrier canada-post is currently unstable.
Posted Jun 09, 2026 - 21:56 EDT
This incident affected: Couriers Tracking System.