USPS - Delayed Tracking Updates
Incident Report for AfterShip
Resolved
This incident has been resolved.
Posted Feb 01, 2021 - 05:53 EST
Update
Carrier is still fixing the issue and we are closely monitoring the status.
Posted Feb 01, 2021 - 04:23 EST
Identified
Due to an ongoing issue at the carrier side, there might be some delay in getting delivery updates. We will keep an eye out and update here once resolved.
slug: usps
Posted Feb 01, 2021 - 01:18 EST
This incident affected: Couriers Tracking System.