[emirates-post] is currently unavailable
Incident Report for AfterShip
Resolved
The incident has been resolved and the services are fully operational.
Posted Nov 10, 2024 - 21:01 EST
Investigating
We have been facing issues while getting the tracking updates for the carrier "emirates-post" since2024-11-07 17:50 HKT

Our team is working on a priority to fix it. We'll update you on the progress
Posted Nov 07, 2024 - 21:59 EST
This incident affected: Couriers Tracking System.