Royal mail is currently partially unavailable
Incident Report for AfterShip
Resolved
The incident has been resolved.
All services are back to normal and operational.
Posted Jan 19, 2025 - 01:33 EST
Update
We have been facing issues while getting the tracking updates for the carrier "royal-mail".

Our team is working on priority to fix it. We'll update you on the progress.
Posted Jan 16, 2025 - 07:31 EST
Investigating
Royal mail is currently partially unavailable
Posted Jan 16, 2025 - 07:30 EST
This incident affected: Couriers Tracking System.