[godependable] is currently unavailable
Incident Report for AfterShip Tracking
Resolved
The incident has been resolved and the carrier is back to normal. We appreciate your patience with us.
Posted Jun 13, 2024 - 07:24 EDT
Update
We are still in touch with the carrier to get it fixed. We'll keep you updated on the progress.

Your patience is highly appreciated.
Posted Jun 11, 2024 - 05:38 EDT
Update
We are continuing to investigate this issue.
Posted Jun 04, 2024 - 05:36 EDT
Investigating
We have been facing issues while getting the tracking updates for the carrier "godependable" since 2024-03-28 17:00 HKT

We are working to fix it on priority. We'll keep you updated on the progress.
Posted May 30, 2024 - 22:31 EDT
This incident affected: Couriers Tracking System.