[kerry-logistics] is currently unavailable
Incident Report for AfterShip
Resolved
The incident has been resolved and the service is fully operational.
Posted Dec 13, 2024 - 04:58 EST
Investigating
We have been facing issues while getting the tracking updates for the carrier "kerry-logistics" since 2024-12-12 14:30:00 UTC.

We are working on it and keep you updated on the progress.
Posted Dec 13, 2024 - 04:55 EST
This incident affected: Couriers Tracking System.