The carrier VESYL is currently unstable.

Incident Report for AfterShip

Resolved

VESYL has resumed their service since 2025-10-05 21:00:00 UTC.
Posted Oct 06, 2025 - 03:07 EDT

Investigating

We are currently investigating this issue.
Posted Oct 05, 2025 - 09:22 EDT
This incident affected: Third party services.