Database performance issue
Incident Report for AfterShip
Resolved
The incident has been resolved and the services are fully operational.
Posted Nov 19, 2024 - 07:28 EST
Update
We are continuing to investigate this issue.
Posted Nov 19, 2024 - 07:19 EST
Investigating
We are currently experiencing a database performance issue that began at 11:15 AM UTC, affecting all products' API latency high.

Our team is actively investigating and prioritizing a resolution. We will keep you updated on our progress
Posted Nov 19, 2024 - 06:54 EST
This incident affected: Public API (Tracking, Returns, Shipping).