Carrier Royal mail [Slug:royal-mai] is currently unavailable. Start Time:- 2026/04/15 8:00 PM UTC

Incident Report for AfterShip

Update

We are continuing to investigate this issue.
Posted Apr 15, 2026 - 16:20 EDT

Investigating

We are currently Investigating the issue.
Posted Apr 15, 2026 - 16:10 EDT
This incident affects: Couriers Shipping System.