Tracking Delay for Courier China Post
Incident Report for AfterShip
Resolved
This incident has been resolved.
Posted Dec 31, 2021 - 03:47 EST
Identified
There is some tracking delay to update for china post. Our Team is working on this.

Affected slugs: 'china-post' & 'china-ems'
Posted Dec 30, 2021 - 21:27 EST
This incident affected: API and Couriers Tracking System.