DPD UK Label Generation Failure - Start Time 2025/09/22 2:44 PM UTC

Incident Report for AfterShip

Resolved

This incident has been resolved.
Posted Sep 22, 2025 - 19:59 EDT

Investigating

DPD UK Services are unavailable resulting in label generation failure, We are checking with the carrier and will post the further updates.
Posted Sep 22, 2025 - 11:39 EDT
This incident affected: Public API (Returns, Shipping) and Third party services.