Carrier USPS [Slug:usps] is currently unavailable. Start Time: 2026/04/19 03:26 AM UTC End Time 2026/04/19 06:07 PM UTC

Incident Report for AfterShip

Resolved

This incident has been resolved and the services have been restored.
Posted Apr 19, 2026 - 22:39 EDT

Investigating

Carrier USPS [Slug:usps] is currently unavailable and we are currently investigating the issue.
Posted Apr 19, 2026 - 08:43 EDT
This incident affected: Couriers Tracking System.