[mondialrelay] is currently unavailable
Incident Report for AfterShip Tracking
Resolved
The incident has been resolved and the carrier is back to normal. We appreciate your patience with us.
Posted Jul 05, 2024 - 03:41 EDT
Update
We are still investigating this issue and will provide you with updates as we make progress.
Posted Jul 04, 2024 - 23:18 EDT
Update
We are continuously investigating this issue and will keep you updated on the progress.
Posted Jul 04, 2024 - 14:42 EDT
Investigating
We have been facing issues while getting the tracking updates for the carrier "mondialrelay" since 2024-07-04 00:00 HKT.

We are working to fix it on priority. We'll update you on the progress.
Posted Jul 04, 2024 - 05:33 EDT
This incident affected: Couriers Tracking System.