[dpd]Tracking System is partial down
Incident Report for AfterShip Tracking
Resolved
The incident has been resolved and the service is fully operational. We appreciate your patience with us.
Posted May 30, 2024 - 01:59 EDT
Update
Most of the issues for the dpd tracking has been resolved but our engineers are still working to resolve it completely.

We'll update the status of the progress.
Posted May 28, 2024 - 06:43 EDT
Investigating
Slug: dpd couriers tracking system has been partially down since 2024-05-27T09:47:03Z, Our engineering team is working to fix it
Posted May 27, 2024 - 07:09 EDT
This incident affected: Couriers Tracking System.