[quantium] is currently unavailable
Incident Report for AfterShip
Resolved
The incident has been resolved and the carrier is back to normal. We appreciate your patience with us.
Posted Jun 28, 2024 - 11:47 EDT
Investigating
We have been facing issues while getting the tracking updates for the carrier "quantium" since 2024-06-28 14:22 HKT.

We are working with the carrier to fix it on priority. We'll update you on the progress.
Posted Jun 28, 2024 - 06:43 EDT
This incident affected: Couriers Tracking System.