[italy-sda] No Tracking Updates
Incident Report for AfterShip
Resolved
The Courier Italy-sda issue has been resolved and we are getting the updates now.
Posted Jul 21, 2023 - 04:22 EDT
Investigating
The Courier Italy-sda is currently unavailable. Our team is working on getting this fixed on priority.
Posted Jul 21, 2023 - 03:32 EDT
This incident affected: Couriers Tracking System.