Cloudflare Outage Impacting Multiple AfterShip Services - Start Time: 2025/11/18 11:40 UTC - End Time: 2025/11/18 14:37 UTC

Incident Report for AfterShip

Resolved

Couriers Shipping System: royal-mail service is back to normal and all requests are now being processed successfully.
Posted Nov 18, 2025 - 10:46 EST

Monitoring

The Royal Mail service is currently being restored.
Most of the requests have been successfully processed and we are continuing to monitor the situation.
Posted Nov 18, 2025 - 10:24 EST

Update

Cloudflare has implemented a fix and services are back to normal. AfterShip's impacted services - AfterShip Help Centre page and Email Marketing Newsletter redirection are working as intended are back to normal.

Couriers Shipping System: royal-mail service is still unavailable.

We will update as soon as Royal Mail services are back to normal
Posted Nov 18, 2025 - 10:16 EST

Investigating

Due to Cloudflare outage, below AfterShip services were impacted:
- Couriers Shipping System: royal-mail service unavailable.
- AfterShip Help Centre page shows error
- Email Marketing Newsletter redirection results in error
Posted Nov 18, 2025 - 09:19 EST
This incident affected: Couriers Shipping System, Support, and Third party services.