[jt-logistics] is currently unavailable
Incident Report for AfterShip Tracking
Resolved
The international parcel service provided by "jt-logistics" is non-operational now, They ceased operations in this sector last week, resulting in the discontinuation of tracking visibility in AfterShip.
We will keep you updated if anything changes.
Posted Mar 07, 2024 - 06:30 EST
Update
We are continuing to investigate this issue.
Posted Mar 07, 2024 - 00:37 EST
Update
We are continuing to investigate this issue.
Posted Feb 29, 2024 - 00:09 EST
Update
We are continuing to investigate this issue.
Posted Feb 28, 2024 - 21:22 EST
Update
The website is still not available, We are continuing to investigate this issue.
Posted Feb 27, 2024 - 04:25 EST
Update
We are still investigating this issue and will continue to provide updates on its status.
Posted Feb 19, 2024 - 02:21 EST
Update
We are continuing to investigate this issue.
Posted Feb 18, 2024 - 01:44 EST
Investigating
We are facing issues while getting the tracking updates with the carrier "jt-logistics" since 2024-02-14 06:15:00 UTC+8, the reason is that can't bypass the captcha no matter if we input the right info. We will keep monitoring this courier.
Posted Feb 18, 2024 - 01:43 EST
This incident affected: API, Public Web Portal, Secure Web Portal, and Couriers Tracking System.